<!-- wp:quote -->

<p>进来教你锐捷常用路由协议</p>
<!-- /wp:quote --> <!-- wp:more --> <!-- /wp:more --> <!-- wp:tadv/classic-paragraph --> <h2>静态路由</h2> <!-- /wp:tadv/classic-paragraph --> <!-- wp:tadv/classic-paragraph --> <h4>交换机配置接口地址</h4>
Ruijie(config)#interface gigabitEthernet0/1

Ruijie(config-GigabitEthernet 0/1)#no switchport  -----> 把接口属性改成路由接口

Ruijie(config-GigabitEthernet 0/1)#ip address 172.16.1.1 255.255.255.0    -----> 配置IP地址

<h4>静态配置</h4>

Ruijie(config)#ip route 172.16.2.0 255.255.255.0 gigabitEthernet 0/1 172.16.1.2  ----->ip route 目的网段   掩码  本地出接口(可选配置)  下一跳(要把数据包发给下一个的地址)
<h2>RIP</h2>
Ruijie(config)#route rip
Ruijie(config-router)#version 2
Ruijie(config-router)#no auto-summary 
Ruijie(config-router)#network 192.168.1.0

<h4>注意这里第三步是关闭自动汇总,这个在华为上是默认配置,但是在锐捷上却不是</h4>
<h4>查看database</h4>

Ruijie#show  ip rip database 
<h2>OSPF</h2>
Ruijie(config)#route ospf 1 

Ruijie(config-router)#network  192.168.1.0 0.0.0.255 area 0

<h4>注意看锐捷这个ospf的配置是宣告完网段之后直接跟区域(area)</h4>
<h4>查看lsdb</h4>

Ruijie#show ip ospf database
<h4>查看邻居状态</h4>
Ruijie#show ip ospf  neighbor 
<h2>BGP</h2> <h3>EBGP</h3>
R1(config)#router bgp 1
R1(config-router)#neighbor 192.168.1.2 remote-as 2
<span class="token function">R1</span><span class="token punctuation">(</span>config-router<span class="token punctuation">)</span>#network 192.168.20.0 mask 255.255.255.0
R1(config-router)#exit
<!-- /wp:tadv/classic-paragraph --> <!-- wp:tadv/classic-paragraph --> <h4>注意这里bgp的as号是1,peer是192.168.1.2。宣告的是192.168.20.0,那么对端也是相反的配置</h4>
R2(config)#router bgp 2
R2(config-router)#neighbor 192.168.1.1 remote-as 1
<span class="token function">R1</span><span class="token punctuation">(</span>config-router<span class="token punctuation">)</span>#network 192.168.10.0 mask 255.255.255.0
R2(config-router)#exit
<h3>IBGP</h3>
R1(config)#router bgp 123       //启用bgp进程,AS号为123

R1(config-router)#neighbor 2.2.2.2 remote-as 123     //指定BGP邻居地址及邻居的AS号

R1(config-router)#neighbor 2.2.2.2 update-source loopback 0       //配置BGP的更新源地址

R1(config-router)#exit

<h4>这里后面这个lookback0就是说更新源是自己的环回口0</h4>
<h4>查看邻居状态</h4>

R2#show ip bgp summary
<h4>查看路由表</h4>
show ip route
<h4>注意这个锐捷的路由表可能跟华为不同</h4> <p></p> <!-- /wp:tadv/classic-paragraph --> <!-- wp:tadv/classic-paragraph --> <h4>前面有个C就是直连,S静态,R(rip),B(BGP),O(ospf),可以看上面那个codes里面有解释。</h4> <!-- /wp:tadv/classic-paragraph -->
最后修改:2020 年 02 月 28 日 06 : 51 PM
请俺喝杯咖啡呗