<!-- wp:quote -->

<p>锐捷的DHCP配置方法略有不同</p>
<!-- /wp:quote --> <!-- wp:more --> <!-- /wp:more --> <!-- wp:tadv/classic-paragraph --> <h2>DHCP</h2> <h3>开启DHCP功能</h3>
    Ruijie(config)#service dhcp
<h3>配置DHCP地址池</h3>
         Ruijie(config)#ip dhcp pool vlan2   ------>创建一个名为 valn2 的DHCP地址池
         Ruijie(dhcp-config)#lease 1 2 3       ------>1、2、3分别是天、时、分,地址释放时间默认为24小时。
         Ruijie(dhcp-config)#network 192.168.2.0 255.255.255.0   ------>可以分配的地址是192.168.2.1~192.168.2.253
         Ruijie(dhcp-config)#dns-server 8.8.8.8  6.6.6.6      ------>8.8.8.8为主DNS,6.6.6.6为备用DNS
         Ruijie(dhcp-config)#default-router 192.168.2.254  ------>分配的网关地址
         Ruijie(dhcp-config)#exit

         Ruijie(config)#ip dhcp pool vlan3
         Ruijie(dhcp-config)#network 192.168.3.0 255.255.255.0
         Ruijie(dhcp-config)#dns-server 8.8.8.8
         Ruijie(dhcp-config)#default-router 192.168.3.254
         Ruijie(dhcp-config)#exit

<h3> 保留部分地址</h3>

          ruijie(config)#ip dhcp excluded-address 192.168.2.1 192.168.2.10    ------>不向客户端分配192.168.2.1~~192.168.2.10的地址
<h3>配置DHCP静态分配地址</h3>
          Ruijie(config)#ip dhcp pool test
          Ruijie(dhcp-config)# client-identifier 01bc.aec5.4bca.8d    ------>针对固定MAC:bcae.c54b.ca8d,加上以太网标识01,即变为01bc.aec5.4bca.8d
          Ruijie(dhcp-config)# host 192.168.2.2 255.255.255.0  ------>分配的ip地址和掩码
          Ruijie(dhcp-config)# dns-server 8.8.8.8 6.6.6.6    ------>分配的主DNS8.8.8.8 和备用的DNS 6.6.6.6
          Ruijie(dhcp-config)# default-router 192.168.2.254  ------>分配的网关

<p>最后别忘了保存配置哦</p>
<h2>DHCP中继</h2>
<p></p>
<h3>需求</h3>
<p>注意:配置之前建议使用 Ruijie#show interface status查看接口名称,常用接口名称有FastEthernet(百兆)、GigabitEthernet(千兆)和TenGigabitEthernet(万兆),以下配置以千兆接口为例:  交换机-1配置vlan 、vlan 的svi地址并把端口划分到相应vlan里;
  交换机-1开启DHCP功能;
  配置DHCP中继功能;
  交换机-2开启dhcp功能,配置DHCP地址池;
  配置到达192.168.2.0及192.168.3.0 这两个网段的路由</p>
<p><span style="color: #ff00ff;">注意:配置之前建议使用 Ruijie#show interface status查看接口名称,常用接口名称有FastEthernet(百兆)、GigabitEthernet(千兆)和TenGigabitEthernet(万兆)</span></p>
<p>以下配置以千兆接口为例:</p>
<h3>交换机-1配置:</h3>
<h4>新建vlan 2、3</h4>

       Ruijie>enable 
       Ruijie#configure terminal
       Ruijie(config)#vlan 2  ------>创建vlan 2
       Ruijie(config-valn)#exit
       Ruijie(config)#int vlan 3
       Ruijie(config-vlan)#exit

<h4>划分接口到相应vlan下</h4>

        Ruijie(config)#interface GigabitEthernet 0/23
        Ruijie(config-if-GigabitEthernet 0/23)# switchport access vlan 3           ------>接口划入vlan3
        Ruijie(config)#interface GigabitEthernet 0/24
        Ruijie(config-if-GigabitEthernet 0/23)# switchport access vlan 2
        Ruijie(config-if-GigabitEthernet 0/23)#intterface range GigabitEthernet0/19-22     ------>从19到22范围端口一起划入vlan2
        Ruijie(config-if-range)#switchport access vlan 2

<h4> 配置vlan2和vlan3的svi口地址(vlan网关地址)</h4>

        Ruijie(config)#interface vlan 2
        Ruijie(config-if-VLAN 3)#ip address 192.168.2.254 255.255.255.0
        Ruijie(config-if-VLAN 3)#exit
        Ruijie(config)#interface vlan 3
        Ruijie(config-if-VLAN 3)#ip address 192.168.3.254 255.255.255.0
        Ruijie(config-if-VLAN 3)#exit

<h4>配置连接 交换机-2 的接口地址</h4>

        Ruijie(config)#interface gigabitEthernet 0/18
        Ruijie(config-if-GigabitEthernet 0/18)#ip address 172.16.1.1 255.255.255.0

<h4>开启DHCP功能</h4>

     Ruijie(config)#service dhcp
<h4>配置DHCP中继</h4>
      Ruijie(config)#ip helper-address 172.16.1.2   ------>172.16.1.2 是DHCP服务器的地址
<h4>保存配置</h4>
      Ruijie(config)#end         
      Ruijie#write     ------> 确认配置正确,保存配置

<h3>交换机-2配置:</h3>
<h4>配置与交换机-1相连的接口地址</h4>

      Ruijie>enable 
      Ruijie#configure terminal
      Ruijie(config)#interface gigabitEthernet 0/1
      Ruijie(config-if-GigabitEthernet 0/1)#no switchport   ------>把接口属性改成路由接口
      Ruijie(config-if-GigabitEthernet 0/1)#ip address 172.16.1.2 255.255.255.0

<h4>开启dhcp功能,配置DHCP地址池</h4>

       Ruijie(config)#service dhcp    ------>开启DHCP功能
       Ruijie(config)#ip dhcp pool vlan2
       Ruijie(dhcp-config)#lease 1 2 3       --------1、2、3分别是天、时、分,地址释放时间默认为24小时。
       Ruijie(dhcp-config)#network 192.168.2.0 255.255.255.0  ------>可以分配的地址是192.168.2.1~192.168.2.25        

       Ruijie(dhcp-config)#dns-server 8.8.8.8  6.6.6.6      --------8.8.8.8为主DNS,6.6.6.6为备用DNS
       Ruijie(dhcp-config)#default-router 192.168.2.254
       Ruijie(dhcp-config)#exit
       Ruijie(config)#ip dhcp pool vlan3
       Ruijie(dhcp-config)#network 192.168.3.0 255.255.255.0
       Ruijie(dhcp-config)#dns-server 8.8.8.8
       Ruijie(dhcp-config)#default-router 192.168.3.254
       Ruijie(dhcp-config)#exit

<h4>配置到达192.168.2.0和192.168.3.0网段的路由</h4>

       Ruijie(config)#ip route 192.168.2.0 255.255.255.0 172.16.1.1
       Ruijie(config)#ip route 192.168.3.0 255.255.255.0 172.16.1.1    

<h4>保存配置</h4>

      Ruijie(config)#end        
      Ruijie#write       ------> 确认配置正确,保存配置

<h4>验证命令:</h4>

    Ruijie#show ip dhcp binding 
        已下发的ip地址      客户端标识(01+mac)    地址租期                    地址分配方式
        IP address        Client-Identifier/               Lease expiration                 Type
                               Hardware address
        192.168.2.1       01bc.aec5.4bca.8d         000 days 23 hours 59 mins   Automatic

<p>资料来自于网络,侵删,文章来源:锐捷网络</p>
<!-- /wp:tadv/classic-paragraph -->

最后修改:2020 年 02 月 28 日 06 : 51 PM
请俺喝杯咖啡呗